Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Verweisfunktionen - BEITRAG: SVERWEIS beim Maximum gleicher Nummern


Aufgabe
In Spalte A stehen (mehrfach) vorkommende Nummern.
In Spalte B stehen die dazugehörigen Mengen.
Ausgegeben werden soll das Land aus Spalte C, wenn die gesuchte Nummer auf ihr Mengen-Maximum in B trifft.
Die gesuchte Nummer steht in D1.

       A               B               C               D       
1 23  1002  Thüringen  23  
2 23  943  Bayern  Hessen  
3 24  2451  Niedersachsen   
4 25  423  Bayern   
5 24  2105  Thüringen   
6 26  3512  Niedersachsen   
7 24  2366  Hessen   
8 23  1033  Hessen   
9 27  877  Hamburg   
10 23  1021  Sachsen   
11 25  410  Thüringen   
12 24  2008  Bayern   


Lösung
in D2 steht:
{=INDEX(C1:C100;VERGLEICH(D1&MAX((A1:A100=D1)*B1:B100);A1:A100&B1:B100;0))}
oder:
{=INDEX(C1:C100;VERGLEICH(D1&MAX(WENN(A1:A100=D1;B1:B100));A1:A100&B1:B100;0))}

Hinweis:
Bei der zweiten Formel dürfen in Spalte B auch Fehlerwerte vorkommen.
Soll als Kriterium das Minimum dienen, funktioniert nur diese Formel.

Weiterer Hinweis:
Um festzustellen, ob das Maximum (bei der gesuchten Nummer) mehrfach auftritt, gib in D3 folgende Matrixformel ein:
=WENN(SUMME(WENN(D1&MAX((A1:A100=D1)*B1:B100)=(A1:A100&B1:B100);1;0))>1;"tritt "&SUMME(WENN(D1&MAX((A1:A100=D1)*B1:B100)=(A1:A100&B1:B100);1;0))&"-fach auf!";"")