Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Verweisfunktionen - BEITRAG: SVERWEIS nach Teilstring suchen


Aufgabe
SVERWEIS vergleicht den Suchbegriff immer mit der kompletten Zelle (ist zumindest ein weit verbreiteter Irrglaube).
Wie kann ich als Schreibfauler nach einem Begriff suchen, der nur einem Teil des Zelleninhaltes entspricht?
Der Teilstring steht am Anfang der Zelle.

       A               B       
1 Karl Uwe Müller  0,98785  
2 Franz Mayer  0,76843  
3 Uwe Schmitt  0,92736  
4 Walter Fricke  0,52263  
5 Uwe Schulz  0,76869  
6 Sven Schneider  0,87502  
7    
8 Uwe 0,92736 

Lösung
Suchspalte: A
Ergebnisspalte: B
Suchbegriff: "Uwe"

Ohne Unterscheidung nach Groß- und Kleinschreibung:
=SVERWEIS("Uwe*";A:B;2;0)
oder auch
=INDEX(B:B;VERGLEICH("Uwe*";A:A;0))

Letztere Variante ist flexibler, denn die Suchspalte braucht nicht links zu stehen.

Mit Unterscheidung nach Groß- und Kleinschreibung:
{=INDEX(B:B;VERGLEICH(FALSCH;ISTFEHLER(FINDEN("Uwe";LINKS(A1:A1000;3)));0))}
Verkürzung
{=INDEX(B:B;VERGLEICH(1;FINDEN("Uwe";A1:A1000));0)}


Erläuterung
Anstelle der 1 in der letzten Formel wird der Suchbegriff dann auch an einer bestimmten Position innerhalb der Zelle gefunden.
Funktioniert statt mit FINDEN natürlich auch mit SUCHEN (beliebige Schreibweise).