Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Mathematische Funktionen - BEITRAG: Schnittpunktkoordinaten von 2 Geraden


Aufgabe
Von 2 Geraden liegen die X- und Y-Koordinaten vor. Die Koordinaten des Schnittpunkts dieser Geraden sollen bestimmt werden.

       A               B               C               D       
1 X  Y  X  Y  
2 13,70  3,3  13,40  1,2  
3 12,80  2  12,90  3,6  
4        
5   Geradengleichungen y =     
6 1,444x      -4,8x  
7 -16,49      65,52  
8        
9   Schnittpunktkoordinaten:     
10   X  Y   
11   13,133  2,48   

Lösung
für die Geradengleichungen steht in A6:
=(B3-B2)/(A3+1/9^9-A2)
und in A7:
=B2+(-A2*(B3-B2)/(A3+1/9^9-A2))

analog in D6 und D7:
=(D3-D2)/(C3+1/9^9-C2)
=D2+(-C2*(D3-D2)/(C3+1/9^9-C2))

das Ergebnis
in B11:
=WENN(RUNDEN(A6-D6;5)=0;"parallel";(D7-A7)/(A6-D6))
und in C11:
=WENN(B11="parallel";"";B11*A6+A7)

DOWNLOAD
(mit Diagramm)


Erläuterung
+1/9^9 bei A3 und C3 in den Geradengleichungen dient nur dazu, bei einer exakt senkrechten Geraden eine Fehlermeldung zu vermeiden.
Bei "zu kurzen" Geraden wird der Schnittpunkt der gedachten Verlängerungen errechnet.