Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: X-Akte - BEITRAG: Seltsames Verhalten von INDIREKT bei diskontinuierlichen Bereichen


Aufgabe
In einem Bereich soll jede zweite Zelle angesprochen werden.
z.B.: A2;A4;A6;A8;A10

Das geht prinzipiell sehr einfach mit
{=INDIREKT("A"&ZEILE(1:5)*2)}

Wenn man diesen Ausdruck jetzt in der Bearbeitungszeile markiert und F9 betätigt, erscheinen die Werte dieser Zellen.

Will man diese Werte summieren, liegt die Formel nahe:
{=SUMME(INDIREKT("A"&ZEILE(1:5)*2))}

Seltsamerweise wird aber so keine Summe gebildet, sondern es erscheint nur der Wert aus A2.


Lösung
Noch seltsamer ist, daß, wenn man um diesen Ausdruck nochmals SUMME ergänzt, also
{=SUMME(SUMME(INDIREKT("A"&ZEILE(1:5)*2)))}
dann funktioniert's.
Aber warum ?

Josef Burch:
{=SUMME(N(INDIREKT("A"&ZEILE(1:5)*2)))}
langt

Statt N(... kann man sonst üblicherweise auch 1*(... nehmen; - das ergibt hier aber #WERT!
? ? ? ? ?

Erläuterung
Statt anfangs {=SUMME(... =SUMMENPRODUKT(... ohne {} funktioniert natürlich auch - aber nicht immer ?

Siehe auch Summenfunktionen (10) Nr. 87