Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Senkrecht aufgebaute Tabelle zeilenweise umsortieren.


Aufgabe
In Spalte A stehen in unregelmäßigen Abständen Bundesländer und in Spalte B dazugehörige Städte. Diese sollen jetzt zeilenweise aufgelistet werden.


       A               B               C               D               E               F               G               H               I       
1 Bayern  München  Bayern  München  Nürnberg  Rosenheim  Passau   
2   Nürnberg  Nordrhein-W.  Monheim  Düsseldorf  Münster  Köln  Bonn  
3   Rosenheim  10  Saarland  Saarlouis         
4   Passau  11  Baden-W.  Stuttgart  Karlsruhe  Freiburg     
5 Nordrhein-W.  Monheim  14  Hessen  Frankfurt  Bad Vilbel       
6   Düsseldorf  16             
7   Münster  16             
8   Köln  16             
9   Bonn  16             
10 Saarland  Saarlouis  16             
11 Baden-W.  Stuttgart               
12   Karlsruhe               
13   Freiburg               
14 Hessen  Frankfurt               
15   Bad Vilbel               


Lösung
in D1 (Formel aus Listen/Datensätze Nr. 160) steht:
{=WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$999<>0;ZEILE($1:$999));ZEILE())))}

in C1 (= Hilfsspalte: ausblenden bzw. unsichtbar formatieren) steht:
=WENN(D1="";ANZAHL2(B:B)+1;VERGLEICH(D1;A:A;0))

C1 und D1 runterkopieren

in E1 steht:
=WENN(SPALTE(A1)>$C2-$C1;"";INDEX($B:$B;SPALTE(A1)+$C1-1))
Bis J10 bzw. soweit wie benötigt kopieren.

Erläuterung
In Spalte A dürfen keine doppelten vorkommen.