Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Solisten, Paare, Dreier, Vierer zählen


Aufgabe
Du willst wissen, wie oft einzelne, doppelte, dreifache usw. Einträge vorkommen.

Beispiel:
={1;1;2;8;2;2;1;4;3;2;5;4;6;7;3}

enthält
4 Solisten (5,6,7,8)
2 Paare(3,4)
1 Dreier(1)
1 Vierer(2)


Lösung
einzelne Einträge:
=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A100;$A$1:$A100)=1)/1)

doppelte (hinten zwei mal die 2 statt 1):
=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A100;$A$1:$A100)=2)/2)

usw.