Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: Sortieren mit Datum vor 1900


Aufgabe
Bei Microsoft fängt die Zeitrechnung erst am 01.01.1900 an.
Wie kann man Datumswerte inklusive Daten vor 1900 sortieren?

       A               B               C               D               E       
1 01.01.1900  1900,084    17.9.0900  900,767  
2 03.12.1870  1871,003    23.4.1111  1111,356  
3 30.01.2002  2002,113    03.12.1870  1871,003  
4 17.9.0900  900,767    01.01.1900  1900,084  
5 23.4.1111  1111,356    09.06.1972  1972,509  
6 09.06.1972  1972,509    30.01.2002  2002,113  
7         (sortiert) 

Lösung
Ein Datum mit einer Jahreszahl kleiner 1900 ist kein Datum sondern Text.
Führende Nullen müssen nicht miteingegeben werden; - optisch wäre es aber besser.
Bei Jahreszahlen <1000 müssen Nullen vorangestellt werden.

Die Daten (echtes Datum und Textdatum) stehen in A1 bis A??

Sortiert absteigend/aufsteigend wird über die die Hilfsspalte B

in B1 steht
=WENN(ISTTEXT(A1);RECHTS(A1;4)+(TEIL(A1;FINDEN(".";A1)+1;FINDEN("#";WECHSELN(A1;".";"#";2))-FINDEN(".";A1)-1))/12+LINKS(A1;FINDEN(".";A1)-1)/1000;JAHR(A1)+MONAT(A1)/12+TAG(A1)/1000)
und runterkopieren