Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Spieler per Zufall mischen


Aufgabe
Zu Beginn einer Spielrunde, z.B. K.O System sollen die teilnehmenden Spieler per Zufall gemischt werden.
Die Mischung soll aber nur zu Beginn der Runde bzw. auf Wunsch durchgeführt werden und nicht bei jeder Neuberechnung.

       A               B               C               D       
1 Agassi  0,6494303  1  Courier  
2 Becker  0,9282597    Becker  
3 Bruguera  0,2663619    Lendl  
4 Connors  0,1518582    Sampras  
5 Courier  0,6104291    Edberg  
6 Edberg  0,2360032    McEnroe  
7 Gomez  0,9985541    Agassi  
8 Ivanisevic  0,0107616    Wilander  
9 Kafelnikov  0,9007106    Bruguera  
10 Leconte  0,0899253    Stich  
11 Lendl  0,3673619    Leconte  
12 McEnroe  0,0724546    Vilas  
13 Sampras  0,7883490    Connors  
14 Stich  0,5865357    Ivanisevic  
15 Vilas  0,5784947    Kafelnikov  
16 Wilander  0,6074983    Gomez 


Lösung
Wähle Extras>Optionen>Berechnung und setze den Haken bei Iteration.
(Anzahl Iterationen ist egal, 1 genügt)

In A1:A16 stehen die Spieler
In B1:B16 steht =ZUFALLSZAHL()

In C1 steht irgendwas, oder auch nicht.

In D1 steht
=WENN($C$1<>0;INDEX(A:A;RANG(B1;$B$1:$B$16));D1)
bis D16 kopieren.

In D1:D16 stehen nun die gemischten Spieler.

Die Mischung erfolgt bei einer Neuberechnung der Tabelle nur, wenn in C1 ein Wert <>0 steht. Steht in C1 0 oder ist die Zelle leer, bleibt die momentane Reihenfolge der Spieler erhalten.


Erläuterung
Ergänzung 25.05.2007:

Eine weitere Alternative zum mischen ohne Makro bietet die Gültigkeitsliste. Dabei benötigen Sie auch keine Excel-Iteration. Siehe Demo-Datei:
DOWNLOAD (5KB)