Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: Staffelpreise festlegen mit SVERWEIS VERWEIS VERGLEICH und MIN


Aufgabe
Wie kann man für bestimmte Mengen Staffelpreise festlegen ?
Lösung
Unter Menge 10 Preis 5
Ab Menge 10 Preis 4
Ab Menge 20 Preis 3
Ab Menge 30 Preis 2
Ab Menge 40 Preis 1

=SVERWEIS(A1;{0.5;10.4;20.3;30.2;40.1};2)
oder
=VERWEIS(A1;{0;10;20;30;40};{5;4;3;2;1})
Statt der Preise 5 - 4 - 3 ... sind alle Zahlen (natürlich auch aufsteigend/gemischt - bzw. auch Texte) einsetzbar.

oder (neu):
=MIN(WENN({0;40;30;20;10}<=A1;{5;1;2;3;4}))
hierbei müssen die Staffelpreise NICHT auf- oder absteigend vorliegen.
<= ist AB Grenzwert nur < wäre BIS Grenzwert.

Sind die Staffelpreise aufsteigend ab 1 durchnumeriert: 1 - 2 - 3 ...
einfacher mit:
=VERGLEICH(A1;{0;10;20;30;40};1)
oder:
=MIN(5;KÜRZEN(A1;-1)/10+1)

Geschweifte Klammern müssen hier manuell eingegeben werden.
Diese Formeln haben den Vorteil, daß sie an keine SUCHMATRIX gebunden sind.