Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Mathematische Funktionen - BEITRAG: Stammbrüche einer Fließkommazahl nach Fibonacci


Aufgabe
Von einer Fließkommazahl sollen die Stammbrüche nach Fibonacci's Nimmersatt-Verfahren ermittelt werden.

       A               B               C               D       
1 0,63      0 + 1/2 + 1/8 + 1/200  
2 0,13  + 1/2   
3 0,005  + 1/2 + 1/8   
4 200  + 1/2 + 1/8 + 1/200   
5 #DIV/0!  #DIV/0!  + 1/2 + 1/8 + 1/200   
6 #DIV/0!  #DIV/0!  + 1/2 + 1/8 + 1/200   
7 #DIV/0!  #DIV/0!  + 1/2 + 1/8 + 1/200   
8 #DIV/0!  #DIV/0!  + 1/2 + 1/8 + 1/200   
9 #DIV/0!  #DIV/0!  + 1/2 + 1/8 + 1/200   
10 #DIV/0!  #DIV/0!  + 1/2 + 1/8 + 1/200   
11 #DIV/0!  #DIV/0!  + 1/2 + 1/8 + 1/200   
12 #DIV/0!  #DIV/0!  + 1/2 + 1/8 + 1/200   

Lösung
In A1 steht die Zahl

A2:=REST(A1;1)-1/B2
B2:=AUFRUNDEN(1/REST(A1;1);0)
C2:=WENN(ISTZAHL(B2);C1&" + 1/"&B2;C1)

A2:C2 bis A12:C12 kopieren.
Zeilen 2 bis 12 ausblenden.

Das Ergebnis (D1) lautet:
=WENN(REST(A1;1)=0;A1;GANZZAHL(A1)&C12)

Erläuterung
Die Ägypter stellten Brüche als Addition von Stammbrüchen (Stammbruch: 1/x) dar, um die Größe mehrerer Brüche besser unterscheidbar zu machen.
z.B. welcher Bruch ist größer: 55/84 oder 7/11 ?
Zerlegt in Stammbrüche ist das leicht zu erkennen:
55/84 = 1/2 + 1/7 + 1/84
7/11 = 1/2 + 1/8 + 1/88
also 55/84, denn 1/7 ist größer als 1/8