Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Summe der letzten Werte unterschiedlich langer Spalten *


Aufgabe
Es soll die Summe von jedem letzten Wert einer Spalte gebildet werden
Die Schwierigkeit liegt darin, dass die Spalten nicht gleich lang sind.


       A               B               C               D               E               F               G               H       
1 92  70  57  76  40    Summe  303  
2 42  99  20  80  75       
3 27  56  62  51         
4 26    94  59         
5 33      46         
6 86               
7 32               

Lösung
{=SUMME(SUMME(INDIREKT("z"&TEILERGEBNIS(3;BEREICH.VERSCHIEBEN(A:A;;SPALTE(A:E)-1))&"s"&SPALTE(A:E);0)))}
ergibt die Summe der letzten Zellen von Spalte A:E

14.08.2007
Eine absolut irre Vereinfachung und leere Spalten dürfen vorkommen von:
Christian Hapke
=SUMMENPRODUKT((A2:E1000="")*A1:E999)

Bis zur letzen Zelle jeder Spalte dürfen keine Leerzellen vorkommen und keine Spalte des Bereichs darf insgesamt leer sein.


Erläuterung
Die mystische Doppel-SUMME !?