Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Summe und Mittelwert von Absolutbeträgen in gefilterter Liste


Aufgabe
In einer gefilterten Liste (Autofilter) soll die Summe der Absolutbeträge gebildet werden.
Ist das Filterkriterium einfach funktioniert es mit:
=SUMMENPRODUKT((C2:C10="x")*ABS(A2:A10))
=SUMMENPRODUKT((C2:C10="x")*ABS(A2:A10))/ZÄHLENWENN(C2:C10;"x") ergibt den Mittelwert.

Sind die Kriterien komplex bzw. ändern sich laufend, ist es mühsam die Formel immer wieder anzupassen.





Lösung
Formel steht in Spalte A unter der gefilterten Liste:

=SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT(ADRESSE(ZEILE(2:10);SPALTE())))*VORZEICHEN(A2:A10))
oder:
=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("B"&ZEILE(2:10)))*ABS(A2:A10))

obige Formel noch dividiert durch TEILERGEBNIS(3;A2:A10) ergibt den Mittelwert.