Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Summe von Textcode, dem ein Wert zugeordnet ist


Aufgabe
In Spalte A steht ein sich wiederholender Textcode (A, B, C, D...).
Jedem dieser Codes ist an anderer Stelle ein bestimmter Zahlenwert zugeordnet (A=15, B=19 etc).
Wie kann man erreichen, daß die Textcodes entsprechend ihrem zugeordneten Zahlenwert aufsummiert werden? (einstufig)


Es gibt auch eine Möglichkeit, den Textcodes einen "Untercode" zuzuordnen.
Jedem dieser Untercodes (x,y,z) ist an anderer Stelle wiederum ein bestimmter Zahlenwert zugeordnet.
Im Beispiel (zweistufig) ist dem Textcode E der Untercode x zugeordnet, und dem Code A ebenfalls Untercode x usw.
Die Aufsummierung berücksichtigt nun die Werte der Untercodes.

Den zweistufigen Fall haben wir noch ergänzt, da in relationalen Datenbanken manchmal über mehrere Stufen Werte mit Schlüsseln verknüpft werden.


       A               B               C               D               E               F               G               H       
1 E    A  15  x    x  5  
2 F    B  19  y    y  4  
3 E    C  8  z    z  3  
4 A    D  6  z       
5 D    E  22  x       
6 A    F  4  y       
7 A               
8 A               
9 B               
10 C               
11 F               
12 D    Summe  280      Summe  84  
13 E    (einstufig)        (zweistufig)   
14 C               
15 E               
16 C               
17 B               
18 D               
19 E               
20 E               

Lösung
In A1 bis A20 stehen sich wiederholende Codes von A-F

Einstufig:

In C1 bis D6 ist jedem Code von A-F ein Wert zugeordnet.

Die Summe ergibt sich aus:
{=SUMME(WENN(MTRANS(A1:A20)=C1:C6;D1:D6;0))}

Zweistufig:

Den Codes in C1:C6 sind ihrerseits weitere Codes von x-z zugeordet. Diese stehen in E1:E6

In G1:H3 sind den Codes x-z Werte zugeordnet.

Die Summe von A1:A20 ergibt sich nun aus
{=SUMME(WENN(A1:A20=MTRANS(C1:C6);MMULT({1.1.1};WENN(MTRANS(E1:E6)=G1:G3;H1:H3;0));0))}