Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Summewenn Datum mit Zeit, Zeit ignorieren


Aufgabe
In einer Spalte soll nach einem bestimmtem Datum gesucht werden und bei jedem Treffer eine benachbarte Spalte summiert werden. Das Problem dabei ist, daß in der zu durchsuchenden Spalte auch Uhrzeiten enthalten sind, die aber hinsichtlich der Suche nicht von Belang sind.

       A               B               C               D       
1 28.04.2001 19:46  500  08.05.01  900  
2 08.05.2001 05:18  300     
3 23.04.2001 14:42  900     
4 20.04.2001 19:36  500     
5 19.04.2001 16:19  800     
6 21.04.2001 14:13  100     
7 22.04.2001 11:26  400     
8 28.04.2001 09:15  600     
9 02.05.2001 06:19  500     
10 28.04.2001 22:58  300     
11 08.05.2001 03:50  600     
12 29.04.2001 13:19  200     
13 26.04.2001 21:45  400     
14 23.04.2001 18:58  800     
15 26.04.2001 17:50  900     

Lösung
Suchspalte A1:A100 (Datum mit Uhrzeit)
Ergebnisspalte B1:B100
Suchkriterium C1 (Datum ohne Uhrzeit)

{=SUMME(WENN(GANZZAHL(A1:A100)=GANZZAHL(C1);B1:B100))}