Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Summewenn für mehrspaltiges Suchkriterium mit "&"-Operator


Aufgabe
Array-Formeln kann man in bestimmten Fällen vereinfachen, in dem man eine durch * dargestellte UND-Operation durch den Verkettungsoperator & ersetzt.

Beispiel SUMMEWENN für mehrerere Kriterien

       A               B               C               D       
1 619  
2 x  y  z  322  
3 423  
4 x  y  z  648  
5 124  
6 x  y  z  651  
7 693  
8   651  
9   762  
10 x  y  z  108  
11        
12        
13 Summe:      1.729 

Lösung
1. Kriterium "x" für Spalte A
2. Kriterium "y" für Spalte B
3. Kriterium "z" für Spalte C

Ergebnisspalte: D

{=SUMME((A1:A100&B1:B100&C1:C100="xyz")*D1:D100)}

statt wie sonst üblich:
{=SUMME((A1:A100="x")*(B1:B100="y")*(C1:C100="z")*D1:D100)}

Falls im Bereich D1:D100 auch Text vorkommen kann, z.B. eine Überschrift, dann
{=SUMME(WENN((A1:A100&B1:B100&C1:C100="xyz");D1:D100))}