Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Summwenn mit zwei Bedingungen für viele Kombinationen


Aufgabe
Wie man eine Summe mit zwei Kriterien berechnet, hat sich mittlerweile rumgesprochen. Nun kann es eine lange Liste mit einer Vielzahl von Kombinationen der zwei Kriterien geben. Nun sollen die Summen aller kombinationen berechnet werden. (Dazu eignet sich natürlich auch eine Pivottabelle).




Lösung
Alternative 1
Die Summe wird beim ersten Vorkommen einer Kombination angezeigt.
D2: {=(SUMME((A$2:A2&B$2:B2=A2&B2)*1)=1)*SUMME(WENN((A$2:A$100=A2)*(B$2:B$100=B2);C$2:C$100))}
(runter kopieren)

Alternative 2
Die Summe wird beim letzten Vorkommen einer Kombination angezeigt.
E2: {=(SUMME((A2:A$101&B2:B$101=A2&B2)*1)=1)*SUMME(WENN((A$2:A$101=A2)*(B$2:B$101=B2);C$2:C$101))}
(runter kopieren)

Alternative 3
Die Summen werden, wie bei einer Pivottabelle, in Tabellenform dargestellt.
Dazu ist die Hilfsspalte F nötig.
F2: =A2&B2

Für diese Alternative müssen alle möglichen Einträge in Spalte A und B bekannt sein. Diese werden dann in die erste Spalte und erste Zeile der Matrix manuell eingegeben.

In H2:H? werden alle unterschiedlichen Einträge aus Spalte A (Krit1) eingetragen.
In I1:?1 werden alle unterschiedlichen Einträge aus Spalte B (Krit2) eingegeben

I2: =SUMMEWENN($F:$F;$H2&I$1;$C:$C)
(nach rechts und unten kopieren)