Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Textfunktionen - BEITRAG: Text oder Zahlen rechtsbündig auf Zellen aufteilen


Aufgabe
Ein Text oder eine Zahl soll ab einer vorgegebenen Spalte rechtsbündig auf mehrere Spalten aufgeteilt werden.

       A               B               C               D               E               F               G               H               I               J       
1 15432    0  
2 123,56        6  
3 1234,98      8  
4                    
5 Excel          l  
6 Jens            s  
7 Walter        r  
8 Boris         

Lösung
In A1:A3 stehen Zahlen

Diese sollen ab Spalte J von rechts aufgeteilt werden. Wenn die Nachkommastellen immer an gleicher Stelle stehen sollen, dann steht in J1
=WENN(SPALTEN(J1:$J1)>LÄNGE(TEXT($A1;"###0,00"));"";LINKS(RECHTS(TEXT($A1;"###0,00");SPALTEN(J1:$J1));1))
Bis B1 kopieren.

Ist die Position der NAchkommastellen egal oder handelt es sich um Text wie in A5:A8 steht in J5
=WENN(SPALTEN(J5:$J5)>LÄNGE($A5);"";LINKS(RECHTS($A5;SPALTEN(J5:$J5));1))
Erläuterung
Linksbündig siehe
http://www.excelformeln.de/formeln.html?welcher=149