Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Über mehrere Tabellen Suchkriterium zählen


Aufgabe
Du willst das vorkommen eines Suchbegriffes in der gesamten Arbeitsmappe zählen.
Dazu müssen die Tabellennamen durchnummerierbar sein.


Lösung
Tabellen: Tabelle1 bis Tabelle10

Suchbegriff: "Hallo"

Die Formel steht in einer Extratabelle, die selbst nicht durchsucht wird:
{=SUMME(ZÄHLENWENN(INDIREKT("Tabelle"&ZEILE(1:10)&"!1:65536");"Hallo"))}

Auflistung aller Tabellen, in denen der Begriff vorkommt, schreibe in Zeile 1:
{="Tabelle"&KKLEINSTE(WENN(ZÄHLENWENN(INDIREKT("Tabelle"&ZEILE($1:$10)&"!1:65536");"Hallo");ZEILE($1:$10));ZEILE())}
und kopiere nach unten.

Steht die Formel in A1 einer der Tabellen, die durchsucht werden, z.B. Tabelle1, muß ein Zirkelbezug vermieden werden:
{=ZÄHLENWENN(2:65536;"Hallo")+ZÄHLENWENN(B1:IV1;"Hallo")+SUMME(ZÄHLENWENN(INDIREKT("Tabelle"&ZEILE(2:10)&"!1:65536");"Hallo"))}

Erläuterung
Für nicht durchnummerierte Tabellen siehe die Summenformel
Nr. 234
Dort nur in den entsprechenden Formeln SUMMEWENN durch ZÄHLENWENN ersetzen.