Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Überprüfung, ob in einer Liste Duplikate enthalten sind


Aufgabe
Es soll geprüft werden, ob in einer Liste Duplikate enthalten sind oder nicht.

Lösung
{=WENN(SUMME(1*(ZÄHLENWENN(A1:A99;A1:A99)>1));"es gibt doppelte Lottchen";"OK")}
oder
{=WENN(UND(ZÄHLENWENN(A1:A99;A1:A99)<=1);"OK";"es gibt doppelte Lottchen")}

Die Zeilenzahl des ersten Treffers liefert:
{=MIN(WENN(ZÄHLENWENN(A1:A99;A1:A99)>1;ZEILE(1:99)))}


Alternative ohne Array-Formel von Roger Herden:
funktioniert aber nur bei Zahlen
="Es gibt "&WENN(ISTFEHLER(MODALWERT(A1:A99));"keine ";"")&"doppelte Lottchen"
oder:
="Es gibt "&WENN(SUMME(1*(HÄUFIGKEIT(A:A;A:A)>1))=0;"keine ";"")&"doppelte Lottchen"
Akzeptiert im Gegensatz zu MODALWERT auch komplette Spalten.