Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zahlensysteme - BEITRAG: Umwandlung von Zahlensystemen ohne Add-In: Binär- in Dezimalzahl


Aufgabe
Wie der Name schon sagt: ersetzt die Analyse-Funktion BININDEZ.
Ab Excel-2013 erledigt das ohne (Einschränkungen) die Winzformel
=DEZIMAL(A1;2)

Vorher:
BININDEZ kann außerdem nur bis zu 9 Zeichen (Bits) - größte Zahl also 511 - umwandeln; - diese Formeln funktionieren bis zur Darstellungsgrenze von Excel = 15 Bits - größte Zahl also: 32.767

       A               B       
1 10110  22  
2 100101001110100  19060  
3 100111111000111  20423  
4 111111111111111  32767  
5 100101001001000  19016 

Lösung
Zahl steht in A1

=SUMMENPRODUKT((LINKS(RECHTS(A1;ZEILE(INDIREKT("A1:A"&LÄNGE(A1))));1)*1)*2^(-1+ZEILE(INDIREKT("A1:A"&LÄNGE(A1)))))

verkürzt:
=SUMMENPRODUKT(LINKS(RECHTS("0"&A1;SPALTE(A:Z)))*2^(-1+SPALTE(A:Z)))

Erläuterung
Vor EXCEL 2007 funktionierte in der zweiten Formel auch die komplette Spalte:
also SPALTE(1:1) statt hier SPALTE(A:Z)