Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zahlensysteme - BEITRAG: Umwandlung von Zahlensystemen ohne Add-In: Dezimal- in Binärzahl


Aufgabe
Wie der Name schon sagt.

Ab Excel-2013 erledigt das ohne (Einschränkungen) die Winzformel
=BASIS(A1;2)

vorher:
Die Add-In-Funktion DEZINBIN kann nur Zahlen bis 511 (2^9)-1 umwandeln; - diese Formeln funktionieren bis 32.768 (2^15) bzw. bis 134.217.728 (2^27)

       A               B       
1 25273  110001010111001  
2 1217  10011000001  
3 30742  111100000010110  
4 27492  110101101100100  
5 28650  110111111101010 

Lösung
Zahl steht in A1

Zahlen bis 2^15
=SUMMENPRODUKT(GANZZAHL(REST(A1/2^(SPALTE(A:Z)-1);2))*10^(SPALTE(A:Z)-1))

Zahlen bis 2^27
=RECHTS(SUMMENPRODUKT(GANZZAHL(REST(A1/2^(ZEILE(16:30)-1);2))*10^(ZEILE(1:15)-1))&TEXT(SUMMENPRODUKT(GANZZAHL(REST(A1/2^(ZEILE(1:15)-1);2))*10^(ZEILE(1:15)-1));WIEDERHOLEN("0";15));GANZZAHL(LN(A1)/LN(2))+1)

Format: 0

Erläuterung
Für Zahlen bis 2^47 siehe Formel Nr. 262