Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zahlensysteme - BEITRAG: Umwandlung von Zahlensystemen ohne Add-In: Dezimal- in Oktalzahl


Aufgabe
Wie der Name schon sagt.
Ersetzt die Analyse-Funktion DEZINOKT

       A               B       
1 Dezimal  Oktal  
2 174  256  
3 633.568.284  4.560.676.034  
4 485.436.348  3.473.625.674  
5 681.696.715  5.050.356.713  
6 154.758.011  1.116.265.573 

Lösung
Zahl steht in A1

Ab Excel-2013 erledigt das ohne (Einschränkungen) die Winzformel
=BASIS(A1;2)

vorher:
{=SUMME(GANZZAHL(REST(A1/8^(SPALTE(A:Z)-1);8))*10^(SPALTE(A:Z)-1))}