Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zahlensysteme - BEITRAG: Umwandlung von Zahlensystemen ohne Add-In: Oktal- in Dezimalzahl


Aufgabe
Wie der Name schon sagt.
Ersetzt die Analyse-Funktion OKTINDEZ

       A               B       
1 Oktal  Dezimal  
2 256  174  
3 210.754.155  35.903.597  
4 163.630.047  30.355.495  
5 241.727.270  42.446.520  
6 521.150.057  88.395.823 

Lösung
Zahl steht in A1

Ab Excel-2013 erledigt das ohne (Einschränkungen) die Winzformel
=DEZIMAL(A1;8)

vorher:
{=SUMME((LINKS(RECHTS(A1;ZEILE(INDIREKT("A1:A"&LÄNGE(A1))));1)*1)*8^(-1+ZEILE(INDIREKT("A1:A"&LÄNGE(A1)))))}

verkürzt:
{=SUMME(LINKS(RECHTS("0"&A1;SPALTE(A:Z)))*8^(-1+SPALTE(A:Z)))}