Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Veraltete Datensätze kenntlich machen


Aufgabe
Du hast Datensätze bei denen Kombinationen aus Spalte A und B mehrfach vorkommen können. Diese unterscheiden sich durch ein Erfassungsdatum.
Bei Wiederholungen sollen die Datensätze mit veraltetem Erfassungsdatum kenntlich machen, um sie gegebenenfalls zu löschen.

       A               B               C               D       
1 Klaus  Kühnlein  11.10.01  veraltet  
2 Andreas  Dusin  23.05.02   
3 Klaus  Kühnlein  22.02.02  veraltet  
4 Jens  Fleckenstein  22.10.01  veraltet  
5 Andreas  Dusin  02.03.02  veraltet  
6 Walter  Fricke  22.10.01  veraltet  
7 Klaus  Kühnlein  18.06.02   
8 Andreas  Dusin  21.08.01  veraltet  
9 Walter  Fricke  07.09.01  veraltet  
10 Jens  Fleckenstein  08.08.01  veraltet  
11 Jens  Fleckenstein  29.04.02   
12 Walter  Fricke  22.04.02   

Lösung
zu vergleichende Spalten: A und B
Erfassungsdatum: C

in D1 steht:
{=WENN(C1=MAX(WENN(A$1:A$100&B$1:B$100=A1&B1;C$1:C$100));"";"veraltet")}

diese Formel bis zum Listenende runterkopieren.