Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Iteration - BEITRAG: Verketten der Primfaktoren einer Zahl zu einem String


Aufgabe
Mit Hilfe der Iteration wird eine Primfaktorenzerlegung durchgeführt. Diese bilden einen String in einer Zelle

       A               B               C               D               E               F               G       
1 2310  100  11  2*3*5*7  2*3*5*7*11  2310  
2              

Gilt für Natürliche Zahlen bis ca. 267.000.000

Siehe dazu auch Nr.167

Lösung
In A1 steht die zu zerlegende Zahl.
Aktiviere unter "Extras-Optionen-Berechnen" die Iteration.

B1:
=WENN(B1=100;1;B1+1)
C1:
=WENN(B1=1;A$1;WENN(D1=0;C1;C1/D1))
D1 Array-Formel:
{=MIN(WENN(REST(C1;ZEILE(INDIREKT("2:"&KÜRZEN(C1^0,5))))=0;ZEILE(INDIREKT("2:"&KÜRZEN(C1^0,5)))))}
E1:
=WENN(B1=1;D1;WENN(D1>1;E1&"*"&D1;E1))
F1 Ergebnis:
=WENN(LINKS(E1&"*"&C1;1)="0";"PRIMZAHL";E1&"*"&C1)

Kontrolle in G1 mit AUSWERTEN:

Wähle Einfügen>Namen>Festlegen
Name:Produkt
Bezieht sich auf:=AUSWERTEN(Tabelle1!$F$1)

Schreibe nun in G1
=Produkt
und Du erhältst wieder das Produkt der Primfaktoren, nämlich den Wert aus A1