Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: Verschachtelte Wenn-Formel ohne die Formel WENN


Aufgabe
Eine Formel mit verschachtelten Bedingungen kann auch ohne WENN erzeugt werden und kann dabei mindestens genauso übersichtlich bleiben.

Beispiel Staffelpreise

Bei einem Ausgangspreis von 10 pro Stück soll in Fünferschritten 0,5 nachgelassen werden, also
ab 6 --> 9,5
ab 11--> 9,0
ab 16--> 8,5

Lösung
statt
=WENN(A1>0;WENN(A1>5;WENN(A1>10;WENN(A1>15;8,5;9);9,5);10);0)
kann man schreiben:
=(A1>0)*(-1*((A1>5)/2+(A1>10)/2+(A1>15)/2)+10)

oder natürlich (Formel 124):
=VERWEIS(A1;{0;1;6;11;16};{0;10;9,5;9;8,5})