Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Vollständigkeits-Statistik *


Aufgabe
Es gibt Kurse, an denen die Teilnehmer teilgenommen haben oder nicht.
Es soll die Anzahl bestimmt werden, die nie gefehlt haben.

       A               B               C               D               E               F               G               H       
1   Kurs 1  Kurs 2  Kurs 3  Kurs 4  Kurs 5  Kurs 6  immer dabei  
2 Beate  2  
3 Boris           
4 Jens    
5 Nonet             
6 WF     


Lösung
Statt der SUMMENPRODUKT-Orgie
=SUMMENPRODUKT((B2:B99="x")*(C2:C99="x")*(D2:D99="x")*(E2:E99="x")*(F2:F99="x")*(G2:G99="x"))

funktioniert:
=SUMME((MMULT(1*(B2:G99="x");ZEILE(1:6)^0)=6)*1)

Steht statt x als Teilnahme was anderes (Datum, Note oder sind anderweitig gefüllt), dann also:
=SUMME((MMULT(1*(B2:G99<>"");ZEILE(1:6)^0)=6)*1)


Erläuterung
Die MMULT-Lösungs-Anregung stammt von Beate Schmitz.