Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Vorgegebene Anzahl von Werten ohne Leerzellen addieren.


Aufgabe
In A1 steht die Anzahl der Werte, die (von links beginnend) im Bereich A2 bis J2 addiert werden sollen, aber nur, wenn die Zellen auch Werte enthalten.
Leerzellen werden dabei ignoriert.


       A               B               C               D               E               F               G               H               I               J       
1 3  6                 
2   -2      0  8   


Lösung
in B1:
{ =SUMME(A2:INDIREKT(ADRESSE(2;KKLEINSTE(WENN(A2:J2<>"";SPALTE(A:J));A1)))) }