Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Vorschlagsliste nach Teileingaben


Aufgabe
Nach Eingabe des ersten, zweiten, dritten ..... Buchstabens/Ziffer sollen alle dann noch vorhandenen Möglichkeiten aufgelistet werden.

       A               B               C               D               E       
1 A11  A113789      ZA123456  
2   a115UT654      A123456  
3   A11-J-KLH      A113789  
4         23-4578  
5         B112790  
6         11123567  
7         a115UT654  
8         A278-UF  
9         R11-887AS  
10         A11-J-KLH  
11         A121-H8Iz  
12         ZA-WF 

Lösung
in A1 gibst Du die Ziffer(n)/Buchstabe(n) ein: eine, zwei, viele.....
In Spalte E der Tabelle1 stehen alle Konten / Artikelnummern oder was auch immer.

folgende Arrayformel in B1 listet Dir dann die Möglichkeiten der Eingabe auf:
{=WENN(SUMME((LINKS(Tabelle1!E$1:E$99;LÄNGE(A$1))=TEXT(A$1;"@"))*1) < ZEILE(A1);"";INDEX(Tabelle1!E:E;KKLEINSTE(WENN(LINKS(Tabelle1!E$1:E$99;LÄNGE(A$1))=TEXT(A$1;"@");ZEILE($1:$99));ZEILE(A1))))}
und runterkopieren

Soll exakte Übereinstmmung vorliegen (a11 in obigem Beispiel würde dann nicht gelistet):
{=WENN(SUMME((IDENTISCH(LINKS(Tabelle1!E$1:E$99;LÄNGE(A$1));TEXT(A$1;"@")))*1) < ZEILE(A1);"";INDEX(Tabelle1!E:E;KKLEINSTE(WENN(IDENTISCH(LINKS(Tabelle1!E$1:E$99;LÄNGE(A$1));TEXT(A$1;"@"));ZEILE($1:$99));ZEILE(A1))))}

Fundstellen irgendwo im Text: siehe Formel Nr. 343 (Listen/Datensätze)