Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zahlensysteme - BEITRAG: Vorsilben für physikalische Maßeinheiten


Aufgabe
Eine Zahl soll in/mit ihrer physikalischen Abkürzung dargestellt werden.
12.300.000 wird zu 12,3 Mega
0,0000123 wird zu 12,3 micro

107 wird zu 1,07 Hekto

Lösung
in tausender Schritten:
=A1/1000^GANZZAHL(LOG(A1)/3)&WAHL(GANZZAHL(LOG(A1)/3)+9;" yocto";" zepto";" atto";" femto";" pico";" nano";" micro";" milli";" ";" Kilo";" Mega";" Giga";" Tera";" Peta";" Exa";" Zetta";" Yotta")

mit centi - dezi - Deka - Hekto:
=WENN(ABS(GANZZAHL(LOG(A1)))<=2;A1/10^GANZZAHL(LOG(A1))&WAHL(GANZZAHL(LOG(A1))+3;" centi";" dezi";" ";" Deka";" Hekto");A1/1000^GANZZAHL(LOG(A1)/3)&WAHL(GANZZAHL(LOG(A1)/3)+9;" yocto";" zepto";" atto";" femto";" pico";" nano";" micro";" milli";" ";" Kilo";" Mega";" Giga";" Tera";" Peta";" Exa";" Zetta";" Yotta"))