Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: WENN mit mehr als 8 Bedingungen *


Aufgabe
Man kann vor Excel-2007 nur bis zu acht WENN-Funktionen ineinander verschachteln.
Wie geht man vor, wenn man mehr als 8 Bedingungen abdecken muss ?

Lösung
Alternative 1
WENN-Funktionen addieren/kombinieren (numerischer Ansatz):
=WENN(A1=1;1;WENN(A1=2;2;.....bis....WENN(A1=8;8;)))+WENN(A1=9;9;WENN(A1=10;10;.....bis....WENN(A1=16;16;)) etc.

Anmerkung:
Addition: mit + muß der Rückgabewert eine Zahl sein.
Kombination: mit & statt + funktioniert das auch bei Text als Rückgabe. Das Ergebnis ist dann aber auch bei Zahlen Text (Josef Burch).

Noch einfacher bei Zahlen als Rückgabewert ist es, Wahrheitswerte zu addieren (Manfred Bartak)
=(A1="a")*1+(A1="b")*2+(A1="c")*3+(A1="d")*4+......+(a1="x")*100
für dieses Beispiel langt auch =CODE(A1)-96

Alternative 2
=wahl(A1;1;2;3....;29) Index von 1 bis 29 möglich

Oder wenn in A1 kein Index steht, geht auch eine Kombi aus WAHL und VERGLEICH, z.B.
=WAHL(VERGLEICH(A1;{"Hund";"Katze";"Pferd";...};0);"bellen";"miauen";"wiehern";...)

Alternative 3
=INDEX({"Fall1";"Fall2";"Fall3"};A1) unbeschränkter Index ab 1 aufwärts möglich.