Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Wie viele unterschiedliche Zeichen (mit Leerzeichen) beinhaltet eine Zelle


Aufgabe
Wie der Titel schon sagt.
Lösung
Text/Zeichen in Zelle A1

Anzahl unterschiedlicher Zeichen:
{=SUMME((VERGLEICH(TEIL(A1;ZEILE(1:1000);1);TEIL(A1;ZEILE(1:1000);1);0)=ZEILE(1:1000))*1)-1}

aaba babc cabc
ergibt 4

Erläuterung
Einschränkungen:
Es wird nicht nach klein- und GROSS-Buchstaben unterschieden.

* sowie ? werden nur an Position 1 erkannt und ~ überhaupt nicht.

Folgende Alternativen unterscheiden Groß- und Kleinschreibung und berücksichtigen * ? ~ richtig:

{=SUMME(1/MMULT(SPALTE(1:1)/SPALTE(1:1);IDENTISCH(TEIL(A1;SPALTE(1:1);1);MTRANS(TEIL(A1;SPALTE(1:1);1)))*1))-1}

ohne Abschluß als Array-Formel:
=SUMMENPRODUKT(1/(LÄNGE(A1)-LÄNGE(WECHSELN(A1;TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1);))))