Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: Wörter nach dem Glücksradprinzip erraten


Aufgabe
Wie der Titel schon sagt.

       A               B               C               D               E               F               G               H               I               J       
1 excellent  _  
2                    
3   e               
4   x               
5   l               
6   m               
7                    
8                    
9                    
10                    
Lösung
In A1 steht das zu erratende Wort. Unter Realbedingungen muß das natürlich ausgeblendet werden.

in B1 steht:
=WENN(SPALTEN($B:B) > LÄNGE($A$1);"";WENN(ZÄHLENWENN($B$3:$B$99;TEIL($A$1;SPALTEN($B:B);1));TEIL($A$1;SPALTEN($B:B);1);"_"))
nach rechts kopieren. hier werden richtig erratene Buchstaben des Wortes eingeblendet. Bei noch nicht erratenen Buchstaben steht der Platzahlter "_".

Ab B3 abwärts werden die geratenen Buchstaben eingegeben.
Ab C3 abwärts werden mit =WENN(B3<>"";ZÄHLENWENN($B$1:$U$1;B3);"")
die Treffer ermittelt.

=ZÄHLENWENN(C3:C17;0) könnte bei Bedarf dann noch die Anzahl Nieten ausgeben.

Erläuterung
Sinnvoller Weise könnte man nun eine Liste mit Wörtern ergänzen, aus der dann per Zufall ein Wort ausgewählt wird.

Siehe als Anregung dazu den Beitrag zum mischen einer Liste: Formel 312