Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: ZÄHLENWENN bei 2 Suchkriterien in wechselnden Spalten *


Aufgabe
Es gibt 2 Kriterien W und F. Wenn diese in der gleichen Zeile (egal, ob in einer oder mehreren Spalten) vorkommen, sollen sie gezählt werden.

       A               B               C               D               E       
1   4  
2 FCKW     
3 GW     
4    
5 W  F     
6      
7 abs  F  W     
8        
9    
10 Salut WF     
11    

Lösung
=SUMMENPRODUKT((ZÄHLENWENN(INDIREKT("A"&ZEILE(1:10)&":C"&ZEILE(1:10));"*W*")>0)*(ZÄHLENWENN(INDIREKT("A"&ZEILE(1:10)&":C"&ZEILE(1:10));"*F*")>0))

Ernst-Albrecht Borgener:
{=ANZAHL((SUCHEN("W";A1:A10&B1:B10&C1:C10))*(SUCHEN("F";A1:A10&B1:B10&C1:C10)))}

neu (08.01.2010):
=SUMME(WENN(MMULT((ZÄHLENWENN(BEREICH.VERSCHIEBEN(A1:C1;ZEILE(1:10)-1;;);{"*W*"."*F*"})>0)*1;{1;1})=2;1))

Erläuterung
Der ersten Formel ist der Vorzug bei einer größeren Spaltenzahl zu geben, da hier die einzelnen Spalten nicht explizit aufgeführt werden müssen.
Sollen nur einzelne Buchstaben gefunden werden (funktioniert nur mit der ersten Formel): die Sternchen bei *W* und *F* weglassen.

Die jetzt dritte ist der Favorit: schon kürzer als die erste, hat sie bei mehreren Kriterien den unschätzbaren Vorteil, dass sie kaum länger wird.
Wird oben zusätzlich noch nach *D* gesucht, muß man nur ergänzen/ändern:
{"*W*"."*F*"."*D*"} und {1;1;1} und =3