Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: ZÄHLENWENN in diskontinuierlichen Bereichen *


Aufgabe
Es soll das Vorkommen eines Begriffs in einem nicht zusammenhängenden Bereich gezählt werden.
Klar könnte man die entsprechenden ZÄHLENWENN addieren.
Praktischer wäre natürlich eine einzige Formel.


       A               B               C               D       
1 x  Jens    6  
2    
3   x  x   
4 Jens    x     
5   WF     
6      
7 WF      Jens   
8          
9 x    x     
10          
11 WF   
12      


Lösung
zu zählender Begriff: x
in den Bereichen A1:A10 - C3:C10 - D3:D5

=SUMME(ZÄHLENWENN(INDIREKT({"A1:A10"."C3:C10"."D3:D5"});"x"))
Spalten und Zeilen gemischt A1:A10 - C3:C10 - B12:H12 funktioniert auch.

Falls es sich nur um nicht zusammenhängende Spalten mit identischen Zeilen handelt (unabhängig von obiger Abbildung - bzw. müsste diese noch um die Spalten E und F erweitert werden):
A1:A10 - C1:C10 - F1:F10 wird es kürzer (Franz Pölt):
=SUMMENPRODUKT((A1:F10="x")*{1.0.1.0.0.1})
oder
=HÄUFIGKEIT((A1:F10="x")*{1.0.1.0.0.1};{1.0})

Erläuterung
Es handelt sich um keine Arrayformeln; - die {geschweiften Klammern} also eingeben.