Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Excel4-Makrofunktionen - BEITRAG: Zählen aller konstanten Zahlen in einem Bereich


Aufgabe
In einem Bereich sollen alle Zellen gezählt werden, die eine Zahl, nicht aber eine Formel enthalten.

Beispiel:
       A       
1 1  
2 =1+1  
3 =A2  
4 =1  
5 3,1415 

liefert das Ergebnis 2
Lösung
Bereich: A1:A1000

vergebe den Namen "Formel"
bezogen auf:
=LINKS(FORMEL.ZUORDNEN(INDIREKT("Tabelle1!$A$"&ZEILE(Tabelle1!$1:$1000)));1)="="

Folgende Array-Formel liefert die Anzahl:
{=SUMME(ISTZAHL(A1:A1000)*(NICHT(Formel)))}

Seit Excel-2013 gibt es die Funktion ISTFORMEL. Damit sind obige Handstände überflüssig:
=SUMMENPRODUKT(ISTZAHL(A1:A1000)*NICHT(ISTFORMEL(A1:A1000)))