Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Zählen ohne Duplikate mit Zusatzbedingungen


Aufgabe
Es sollen Datensätze gezählt werden, die mehrere Bedingungen erfüllen, aber ohne Duplikate.

Also quasi eine Kombination der Formeln 44 und 273

       A               B       
1 4  C  
2 4  A  
3 A  
4 A  
5 B  
6 4  B  
7 A  
8  
9 D  
10    
11 Ergebnis  3 


Lösung
Es sollen alle unterschiedlichen, nichtleeren Zellen in Spalte B gezählt werden, in denen gleichzeitig in Spalte A eine 4 steht.

=SUMMENPRODUKT((VERGLEICH(A1:A10&B1:B10;A1:A10&B1:B10;0)=ZEILE(X1:X10))*(A1:A10=4)*(B1:B10<>""))

oder als Arrayformel:
{=SUMME(WENN((A1:A10=4)*(B1:B10<>"");1/ZÄHLENWENNS(B1:B10;B1:B10;A1:A10;4)))}
dito mit ANZAHL
{=ANZAHL(1/((VERGLEICH(4&B1:B10;A1:A10&B1:B10;0)=ZEILE(X1:X10)*(B1:B10<>""))))}

Stehen in Spalte B nur Zahlen, funktioniert es auch mit Häufigkeit:
{=SUMME(1*(HÄUFIGKEIT(WENN((A1:A10=4)*(B1:B10<>"");B1:B10);B1:B10)>0))}