Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Zeichen über mehrere Zellen zählen mit Array-Formel


Aufgabe
Ein "Einzeller" kann auch über mehrere Zellen ausgeweitet werden.
Dadurch wird ein zweidimensionaler Array erzeugt.
Hier soll ein bestimmtes Zeichen über mehrere Zellen gezählt werden.

       A               B       
1 Janua  
2 Februa  
3 März   
4 April   
5 Ma  
6 Juni   
7 Juli   
8 August   
9 September   
10 Oktober   
11    
12 1.Formel  6  
13 2.Formel  2 

Lösung
gesuchtes Zeichen "A"

{=SUMME((TEIL(A1:A10;SPALTE(1:1);1)="A")*1)}

oder (länger, aber vielleicht verständlicher):
{=SUMME(LÄNGE(A1:A10))-SUMME(LÄNGE(WECHSELN(A1:A10;"A";"")))}

!!!Die erste Formel unterscheidet nicht zwischen Groß- und Kleinschreibung, die zweite schon.!!!