Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Zellen mit bestimmter Anzahl an Zeichen Zählen


Aufgabe
Es sollen alle Wörter gezählt werde, die eine Länge von 5 Zeichen haben, oder die eine Länge von mindestens/höchstens 5 Zeichen haben
Lösung
Zahlen und Texte stehen in Spalte A

genau 5 Zeichen, funktioniert nur bei Text, nicht bei Zahlen
=Zählenwenn(A:A;"?????")

oder besser als Array-Formel (für Text und Zahlen)
{=SUMME(1*(LÄNGE(A1:A100)=5))}

mindestens 5 Zeichen (höchstens: <=)
{=SUMME(1*(LÄNGE(A1:A100)>=5))}

mindestens 5 Zeichen (nur Text)
=ZÄHLENWENN(A:A;"?????*")

höchstens 5 Zeichen (nur Text)
=ANZAHL2(A:A)-ZÄHLENWENN(A:A;"??????*")