Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Textfunktionen - BEITRAG: Ziffern beliebiger Anordnung aus einem Text extrahieren


Aufgabe
Wie können beliebige Ziffern aus einem Text beliebiger Länge gezogen werden ?

Beispiel:
1qw23er45 --> 12345
01qw96er78 --> 019678

Lösung
ignoriert führende Nullen:

{=SUMME((TEIL(0&A1;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A1;ZEILE($1:$256);1)*1);ZEILE($1:$256);1);ZEILE($1:$256));1)*1)*10^(ZEILE($1:$256)-1))}

beachtet führende Nullen:

{=TEXT(SUMME((TEIL(0&A1;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A1;ZEILE($1:$256);1)*1);ZEILE($1:$256);1);ZEILE($1:$256));1)*1)*10^(ZEILE($1:$256)-1));WIEDERHOLEN(0;SUMME(ISTZAHL(TEIL(A1;ZEILE($1:$256);1)*1)*1)))}

Achtung: Wegen der Rechengenauigkeit von Excel ist nach 15 Ziffern Sense.
Fließkommazahlen werden nicht extrahiert.

Erläuterung
Das Gegenteil - also alle Ziffern eliminieren: siehe Formel Nr. 174