Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Zufallsbereich mit gewichteter Eintrittswahrscheinlichkeit


Aufgabe
Aus einem Zahlenbereich von 1 bis n soll zufällig einen Zahl gezogen werden. Die Eintrittswahrscheinlichkeit soll aber nicht gleichverteilt sondern gewichtet sein.
Lösung
In A1:An stehen die Eintrittswahrscheinlichkeiten, hier z.B. für sieben:
{0,05;0,05;0,1;0,1;0,3;0,2;0,2}
(Die Summe muß immer 1 ergeben)

Das Ergebnis ist
{=MIN(WENN(ZUFALLSZAHL()<=TEILERGEBNIS(9;INDIREKT("A1:A"&ZEILE(INDIREKT("1:"&ANZAHL($A:$A)))));ZEILE(INDIREKT("1:"&ANZAHL($A:$A)))))}

In annähernd 30% der Fälle sollte im Beispiel also eine 5 rauskommen.

Geht der Zahlenbereich nicht von 1-n kontinuierlich, dann nimmt man die Funktion Index zu Hilfe:

{=INDEX({1;3;5;7;10;15;20};MIN(WENN(ZUFALLSZAHL() < TEILERGEBNIS(9;INDIREKT("A1:A"&ZEILE(INDIREKT("1:"&ANZAHL($A:$A)))));ZEILE(INDIREKT("1:"&ANZAHL($A:$A))))))}

kumulierte Wahrscheinlichkeit mit Hilfsspalte:
B1 steht =SUMME(A$1:A1) bis B7 kopieren.
Nun genügt die Formel
{=MIN(WENN(ZUFALLSZAHL()<=B1:B7;ZEILE(B1:B7)))}

19.09.2007 - ohne Arrayformeln und Hilfsspalte funktionieren auch folgende "Formel-Knallfrösche":
=VERGLEICH(ZUFALLSZAHL();{0;0,05;0,1;0,2;0,3;0,6;0,8})
und
=INDEX({1;3;5;7;10;15;20};VERGLEICH(ZUFALLSZAHL();{0;0,05;0,1;0,2;0,3;0,6;0,8}))


Erläuterung
Mit den auf INV endenden Statistikfunktionen, können Zufallszahlen in Anlehnung an eine der in Excel verfügbaren Wahrscheinlichkeitsverteilungen generiert werden.
Beispielsweise erzeugt die Formel
=NORMINV(ZUFALLSZAHL();7;2)
normalverteilte Zufallszahlen mit dem arithmetischen Mittelwert 7 und der Standardabweichung 2.