Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zahlensysteme - BEITRAG: Zwei Binärzahlen multiplizieren


Aufgabe
Zwei Binärzahlen sollen multipliziert werden. Das Produkt soll auch als Binärzahl dargestellt werden.

       A               B               C               D               E       
1 11111111  Zahl 1    255   
2 101010  Zahl 2    42   
3 10100111010110  Produkt    10710  10100111010110 

Lösung
Die zwei Zahlen stehen in A1:A2

Ab Excel2013 gibt es die Funktionen BASIS und DEZIMAL - dann langt ohne Einschränkungen:
=BASIS(DEZIMAL(A1;2)*DEZIMAL(A2;2);2)

Vorher:
{=SUMME(GANZZAHL(REST(PRODUKT(MMULT(LINKS(RECHTS("0"&A1:A2;SPALTE(A1:IQ1)))*2^(-1+SPALTE(A1:IQ1));ZEILE(1:251)/ZEILE(1:251)))/2^(SPALTE(A1:IQ1)-1);2))*10^(SPALTE(A1:IQ1)-1))}

liefert das Produkt.

zum Beweis werden in D1:D3 die Binärzahlen in Dezimalzahlen umgerechnet und
deren Produkt wieder in eine Binärzahl umgerechnet

Es können auch mehr als zwei Zahlen sein, das Produkt darf Binär aber nicht mehr als 15 Stellen haben.