Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Zwischensumme am Ende einer Gruppe bilden, Sortierung egal


Aufgabe
In einer Spalte sollen Zwischensummen einer Betragsspalte am letzten Eintrages jedes Kriteriums einer Kriterienspalte gebildet werden.
Im Gegensatz zur Funktion Daten>Teilergebnisse soll das auch ohne Sortierung der Kriterienspalte möglich sein.

       A               B               C       
1 850  Bill   
2 540  Walter   
3 754  Jens   
4 564  Bill   
5 322  Walter   
6 663  Walter   
7 218  Jens   
8 423  Andy   
9 409  Bill  1823  
10 599  Walter   
11 103  Klaus  103  
12 443  Jens   
13 860  Walter   
14 765  Walter  3749  
15 354  Andy   
16 408  Andy   
17 403  Jens   
18 704  Andy   
19 390  Andy  2279  
20 324  Jens  2142 

Lösung
Betragsspalte = A
Kriterienspalte = B

ab C1 steht
=WENN(ZÄHLENWENN(B1:B10000;B1)>1;"";SUMMEWENN(B:B;B1;A:A))
(runter kopieren)