Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Zwischensummen bis zur nächsten Leerzelle bilden und numerieren


Aufgabe
In einer Spalte sind Wertebereiche variabler Länge durch Leerzeilen getrennt. Am Ende jedes "Zahlenblockes" soll immer eine Summe der einzelnen Zahlenblöcke gebildet werden.
Die Anzahl Zahlen pro Block ist variabel.

       A               B               C       
1 850     
2 540  1.390  1  
3      
4      
5 322     
6 663     
7 218  1.203  2  
8      
9 409     
10 599     
11 103     
12 443     
13 860  2.414  3  
14      
15      
16      
17 403     
18 704     
19 390  1.497  4 

Lösung
Werte stehen in Spalte A ab A1

in B2 steht
=WENN(UND(A2<>"";A3="");SUMME(A$1:A2)-SUMME(B$1:B1);"")

in C2 steht
=WENN(B2<>"";MAX(C$1:C1)+1;"")

(runter kopieren)