Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: alle Zellen auflisten, die eine bestimmte Zeichenfolge enthalten


Aufgabe
Es sollen alle Zellen einer Spalte lückenlos aufgelistet werden, die an irgendeiner Position einen bestimmten Suchbegriff (Teilstring) enthalten.


       A               B               C               D       
1 Chronik    AGB  Nachfolgend die AGB  
2 Nachfolgend die AGB      Die AGB stehen auf ...  
3 ein tragbares Ergebnis      AGB  
4 Siemens      es gelten die AGB vom ...  
5 Die AGB stehen auf ...       
6 AGB       
7 Excel ist unschlagbar       
8 Es gelten die AGB vom ...       
9 agb       
10 excelformeln.de       

Lösung
Spalte A1:A100; - Suchbegriff ist "AGB" bzw. steht in Zelle C1 (ohne Anführungszeichen).

Die Formel in D1 lautet:
{=WENN(ZEILE()>SUMME(ISTZAHL(FINDEN("AGB";A$1:A$100))*1);"";INDEX(A:A;KKLEINSTE(WENN(ISTZAHL(FINDEN("AGB";A$1:A$100));ZEILE($1:$100));ZEILE(A1))))}
und runterkopieren

Steht der Suchbegriff in Zelle C1, dann in der Formel "AGB" durch C$1 ersetzen.
Soll nicht nach Groß- und Kleinschreibung unterschieden werden, dann FINDEN durch SUCHEN ersetzen.