Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Bedingte Formatierung - BEITRAG: alle Zellen mit Suchbegriff markieren


Aufgabe
Alle Zellen, die den Suchbegriff enthalten sollen markiert werden. Dabei soll wahlweise die Funktion SUCHEN bzw. FINDEN (exakte Schreibweise) angewandt werden und ob nur die ganze Zelle oder auch Teilstring.

Lösung
Grundidee:
Markiere A1 bis z.B. E20 (A1 ist die aktive Zelle)
Format / bedingte Formatierung / Formel ist
=SUCHEN("Text";A1)
und ein Format aussuchen (z.B.: Muster - gelb)


Das läßt sich auch dynamisieren:

Der Suchbegriff wird in Zelle F1 eingegeben
Bei Eingabe von 1 in Zelle F2 wird die SUCHEN-Funktion angewandt, Groß- und Kleinschreibung spielt dann keine Rolle
bei 0 in F2 wird die FINDEN-Funktion angewandt, Groß- und Kleinschreibung wird beachtet.
F2 benutzerdefiniert formatieren mit
[=1]"SUCHEN";[=0]"FINDEN";Standard

Bei Eingabe von 1 in G2 werden nur ganze Zellen berücksichtigt; - bei 0 auch Teilstrings
G2 benutzerdefiniert formatieren mit
[=1]"ganze Zellen";[=0]"Teilstring";Standard

Markiere A1 bis z.B. E20 (A1 ist die aktive Zelle)
Format / bedingte Formatierung / Formel ist
=WENN($F$2=1;SUCHEN($F$1;A1);FINDEN($F$1;A1))*WENN($G$2=1;LÄNGE(A1)=LÄNGE($F$1);1)
und ein Format aussuchen (z.B.: Muster - gelb)