Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Textfunktionen - BEITRAG: alle vorkommenden Zeichen in mehreren Zellen auflisten


Aufgabe
In A1 bis A? stehen Wrter / Zeichenfolgen. Es sollen alle darin vorkommenden Zeichen (solo) aufgelistet werden.

       A               B               C               D               E       
1 assssq  assssqfafy-908-aWFf-8-sa90  asqfy-908WF  
2 f afy  ssssqffy-908-WFf-8-s90   
3 -908-a  qffy-908-WFf-8-90  -089FWafqsy  
4 WF  ffy-908-WFf-8-90   
5 f - 8 - s  y-908-WF-8-90   
6 a 90  -908-WF-8-90     
7   -908-WF-8-90   
8   908WF890   
9   08WF80   
10   8WF8   
11   WF     
12   WF     
13      


Lösung
in B1 steht:
=WECHSELN(A1&A2&A3&A4&A5&A6&A7&A8&A9&A10&A11&A12&A13&A14&A15&A16;" ";)
in B2:
=WECHSELN(B1;C1;"")
in C1:
=LINKS(B1)
B2 und C1 runterkopieren

das Ergebnis in einer Zelle dann:
=C1&C2&C3&C4&C5&C6&C7&C8&C9&C10&C11&C12&C13&C14&C15&C16

Sollen die Zeichen sortiert (entsprechend der Codezahl) vorliegen, dann in D1:
{=WENN(B1="";"";ZEICHEN(KKLEINSTE(CODE(WENN(C$1:C$20="";ZEICHEN(255);C$1:C$20));ZEILE(A1))))}
runterkopieren

in einer Zelle:
=D1&D2&D3&D4&D5&D6&D7&D8&D9&D10&D11&D12&D13&D14&D15&D16


Erläuterung
Es werden jetzt GROSS- und kleinbuchstaben unterschieden.
Ist dies nicht gewnscht, um B1 KLEIN() bzw. GROSS() drumrum.