Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: die Funktion RANG funktioniert nicht in gefilterter Liste


Aufgabe
Die Funktion RANG() ist eine Mimose: sie funktioniert nicht in Arrayformeln (siehe Nr. 492) und sie will auch mit TEILERGEBNIS nichts zu tun haben.

So funktioniert die Rangliste in einer gefilterten Tabelle:

       A               B               C               D               E               F               G               H               I       
1 Pkt.  Rang            gefiltert   
2 0,04  17  Israel    0,04  7  Israel  E  
3 24  3  Italien    24  1  Italien  E  
4 30,3  2  Jamaika    2,12  4  Kasachstan  E  
5 9,37  7  Japan  As    2,13  3  Kroatien  E  
6 0,01  18  Kaimaninseln    0,41  6  Lettland  E  
7 2,07  12  Kamerun    3,85  2  Litauen  E  
8 14,40  5  Kanada    1,00  5  Luxemburg  E  
9 2,12  11  Kasachstan           
10 0,76  14  Katar  As           
11 43  1  Kenia           
12 0,45  15  Kolumbien           
13 2,13  10  Kroatien           
14 18,7  4  Kuba           
15 0,41  16  Lettland           
16 3,85  9  Litauen           
17 13  Luxemburg           
18 10,3  6  Marokko           
19 4,61  8  Mexiko           

Das ist ein Auszug aus der Leichtathletik-Medaillenstatistik gefiltert dann nach E (Europa) in Spalte D.


Lösung
in B2:
{=WENN(A2="";"";SUMME(1*(A2 < WENN(TEILERGEBNIS(3;INDIREKT("A"&ZEILE($2:$199)));A$2:A$199;-9^9)))+1)}

ohne {Arrayformel}:
=WENN(A2="";"";SUMMENPRODUKT(1*(A2 < TEILERGEBNIS(3;INDIREKT("A"&ZEILE($2:$99)))*(A$2:A$99)))+1)

jeweils runterkopieren

Erläuterung
Einschränkungen:
Im Bereich der Spalte A dürfen keine Texte vorkommen - Leerzellen schon.
Die SUMMENPRODUKT-Variante funktioniert nur mit Zahlen >=0