Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Tabellennavigation - BEITRAG: die Position der nächsten größeren folgenden Zahl bestimmen *


Aufgabe
Gemeint ist NICHT die nächsthöhere Zahl sondern die, die als erste größere danach folgt. Dabei weiß man nicht, wo die Zahl (aus C1) erstmals steht.

       A               B               C       
1   4  
2    
3   Zeile  
4 4    8  
5    
6   Inhalt  
7   12  
8 12     
9    
10    





Lösung
Die Zeile ergibt:
{=MIN(WENN(INDEX(A:A;VERGLEICH(C1;A:A;0)):A99>C1;ZEILE(INDEX(A:A;VERGLEICH(C1;A:A;0)):A99)))}

kürzer (ohne Bereichsberechnung) von Josef Burch:
{=VERGLEICH(1;(A1:A99>C1)*(ZEILE(1:99)>VERGLEICH(C1;A1:A99;0));0)}

Ist sicher, dass vor'm ersten Auftauchen der Zahl keine höhere vorkommt, ist's easy:
{=VERGLEICH(WAHR;(A1:A99)>C1;0)}

Für den Inhalt logischerweise den INDEX drumrum:
{=INDEX(A:A;Formel)}


Erläuterung
Falls das Ergebnis in eine weiterführende Berechnung einfließen soll:
Bei keiner folgenden größeren Zahl ergibt die erste Formel 0 (Null) - die beiden anderen: #NV