Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: die Summe der Zeilenmaxima bilden


Aufgabe
In den Zeilen von jeweils Spalte A bis E stehen Werte.
Die jeweiligen Maxima sollen addiert werden.

       A               B               C               D               E               F               G               H       
1 17  52  714  157    714  1183  
2 48  52  87  157    157   
3   42  41    42   
4       100  232    232   
5 37    17  20      37   
6       1       

Lösung
Einfachste Lösung:
in Hilfsspalte G1 steht =MAX(A1:E1)
runterkopieren
Das Ergebnis ist dann =SUMME(G:G)

Ohne Hilfsspalte:
=SUMMENPRODUKT(TEILERGEBNIS(4;BEREICH.VERSCHIEBEN(A1:E1;ZEILE(1:99)-1;)))

Die Summe der Spaltenmaxima wäre:
=SUMMENPRODUKT(TEILERGEBNIS(4;BEREICH.VERSCHIEBEN(A1:A99;;SPALTE(A:E)-1)))